summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2021-03-17 15:33:59 +0000
committerChris Liddell <chris.liddell@artifex.com>2021-03-17 15:53:07 +0000
commit5459f7aca1ded3b7cf96c339a2419f418aa406c7 (patch)
tree6ebbc7b549145df121ae9147b9822ca118eab3eb /configure.ac
parenta03ce3d6a130c843cb4dd91b7e767706973b4e22 (diff)
downloadghostpdl-5459f7aca1ded3b7cf96c339a2419f418aa406c7.tar.gz
Make --disable-threads incompatible with including OCR
Tesseract requires threading, even though Ghostscript doesn't actually call any of the parts of tesseract that use threading, there is no sensible way to leave it out. So, throw an error if --disable-threads is used when tesseract/leptonica is present. The error includes a note to use "--without-tesseract" to avoid the error. Also, fix a typo from a03ce3d6a130c843cb4dd91b7e767706973b4e22
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6a55593ae..0ebe94576 100644
--- a/configure.ac
+++ b/configure.ac
@@ -848,10 +848,12 @@ if test x$with_tesseract != xno; then
AC_LANG_PUSH(C++)
AC_TRY_COMPILE([],
[return 0;],
- [HAVE_CXX_COMPILER=yes, AC_SUBST(CXX)],
+ [HAVE_CXX_COMPILER=yes; AC_SUBST(CXX)],
[HAVE_CXX_COMPILER=no])
if test x$HAVE_CXX_COMPILER != xyes; then
AC_MSG_WARN([Disabling tesseract as no working C++ compiler])
+ elif test x$SYNC = xnosync ; then
+ AC_MSG_ERROR([Threading disabled or not available. Tesseract OCR relies on threading. Rerun configure with "--without-tesseract" to exclude OCR from the build])
else
dnl --------------------------------------------------
dnl check for sse4.1, avx, avx2 or fma