summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2018-08-17 15:44:38 +0200
committerJens Georg <mail@jensge.org>2018-08-17 17:01:10 +0200
commit3492123f5997b3760ea21be597bfc8f2bf3ba1e1 (patch)
treed57ddc88bc05e7722a452d771cca6eedee21242c /meson.build
parent6c9ebf96f59c71e572a6791b789835877e75c2c1 (diff)
downloadgssdp-3492123f5997b3760ea21be597bfc8f2bf3ba1e1.tar.gz
meson: Use meson-style options
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index b8112ad..773e259 100644
--- a/meson.build
+++ b/meson.build
@@ -81,19 +81,19 @@ gobject_dep = dependency('gobject-2.0', version : '>= 2.32')
gio_dep = dependency('gio-2.0', version : '>= 2.32')
soup_dep = dependency('libsoup-2.4', version : '>= 2.26.1')
-if not get_option('without-gtk')
+if get_option('ui')
gtk = dependency('gtk+-3.0', version : '>= 3.12', required: false)
endif
gir = find_program('g-ir-scanner', required: false)
vapigen = find_program('vapigen', required: false)
-introspection_available = gir.found() and not get_option('disable-introspection')
-vapi_available = introspection_available and vapigen.found() and not get_option('disable-vala')
+introspection_available = gir.found() and get_option('introspection')
+vapi_available = introspection_available and vapigen.found() and get_option('vapi')
subdir('libgssdp')
subdir('tests')
-if not get_option('without-gtk') and gtk.found()
+if get_option('ui') and gtk.found()
subdir('tools')
endif
@@ -101,6 +101,6 @@ if vapi_available
subdir('vala')
endif
-if get_option('enable-gtk-doc')
+if get_option('docs')
subdir('doc')
endif