summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-12-29 15:58:47 +0000
committerXavier Claessens <xclaesse@src.gnome.org>2007-12-29 15:58:47 +0000
commite4358acdec7b8c278a1950a3da24bab387a0e7b3 (patch)
tree9a15f253d9c45a90a8794143ecdd854650d58af1 /Makefile.am
parentb8607414ea0e41c44a09d31ebcd0437a3c867a24 (diff)
downloadtelepathy-account-widgets-e4358acdec7b8c278a1950a3da24bab387a0e7b3.tar.gz
Revert "merge git work"
This reverts commit 0cfd80847f0d66967f56c7d6b3eb46793f725859. svn path=/trunk/; revision=519
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 4256f0f8..2d207666 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,6 +33,7 @@ EXTRA_DIST = \
$(INTLTOOL)
DISTCLEANFILES = \
+ ChangeLog \
intltool-extract \
intltool-merge \
intltool-update
@@ -41,15 +42,9 @@ DISTCLEANFILES = \
# uninstall.
distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
-# Build ChangeLog from SVN history (r470 was the first ChangeLog-less checkin).
-# Only build this when in an svn checkout.
-
-ChangeLog:
- @if test -f $(top_srcdir)/.svn/entries; then \
- svn log -v --xml -r HEAD:470 $(SVN_ROOT)/$(SVN_MODULE) | \
- xsltproc --stringparam strip-prefix "$(SVN_MODULE)/$(SVN_BRANCH)" \
- --stringparam include-rev "yes" $(top_srcdir)/svn2cl.xsl - > $@; \
- fi
+ChangeLog: Makefile.am
+ git-log --pretty=short > ChangeLog
+
dist: ChangeLog