summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Barisione <marco.barisione@collabora.co.uk>2013-08-22 11:46:21 +0100
committerMarco Barisione <marco.barisione@collabora.co.uk>2013-08-22 12:52:59 +0100
commitee70418cea9bb97223589087aa6a970860f147a6 (patch)
treecc775fa9932be46d61d718ffa1e1e6deb5416038 /configure.ac
parent84d26bd9c0301340e1a07bec29a139912e959b32 (diff)
downloadtelepathy-account-widgets-ee70418cea9bb97223589087aa6a970860f147a6.tar.gz
build: add --with-icondir to set a different install path for icons
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 15 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 671dbfa3..82f5e6f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,12 +130,11 @@ fi
AC_SUBST(LDFLAGS)
# -----------------------------------------------------------
-# Allow to overwrite where to install icons and other data
-# files
+# Allow to overwrite where to install data files
# -----------------------------------------------------------
AC_ARG_WITH([pkgdatadir],
AS_HELP_STRING([--with-pkgdatadir],
- [set a different directory where to install the icon]),,
+ [set a different directory where to install data files]),,
with_pkgdatadir=)
if test x"$with_pkgdatadir" != x"" ; then
@@ -145,6 +144,18 @@ else
fi
AC_SUBST(real_pkgdatadir)
+AC_ARG_WITH([icondir],
+ AS_HELP_STRING([--with-icondir],
+ [set a different directory where to install icons]),,
+ with_icondir=)
+
+if test x"$with_icondir" != x"" ; then
+ icondir="${with_icondir}"
+else
+ icondir="${real_pkgdatadir}/icons"
+fi
+AC_SUBST(icondir)
+
# -----------------------------------------------------------
# Pkg-Config dependency checks
# -----------------------------------------------------------
@@ -358,6 +369,7 @@ Configure summary:
Linker Flags................: ${LDFLAGS}
Prefix......................: ${prefix}
Data directory .............: ${real_pkgdatadir}
+ Icon directory .............: ${icondir}
Coding style checks.........: ${ENABLE_CODING_STYLE_CHECKS}
Unreleased version checks...: ${enable_unreleased_checks}
GETTEXT_PACKAGE.............: ${GETTEXT_PACKAGE}