summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2022-04-02 19:09:23 +0200
committerCarlos Garnacho <carlosg@gnome.org>2022-04-02 21:55:05 +0200
commitaa94f2f8e2c580815c19d261c7b3f91237011f3e (patch)
tree47a564f06ba4e638d501c68cfdf9400107a1bddc /meson.build
parentde16136f286d11af8ada333b67f95ec6155d891e (diff)
downloadtracker-aa94f2f8e2c580815c19d261c7b3f91237011f3e.tar.gz
libtracker-fts: Drop in-tree fts5 module
This was only a last resort for sqlite < 3.20, since module loading API changed around that version, also it probably did us a disservice since we barely updated the fts5.c file. We no longer accept such old versions and we expect that sqlite has a builtin FTS5 module, so we can drop this.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 2 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 1ae34ceb4..d3f6da31d 100644
--- a/meson.build
+++ b/meson.build
@@ -191,21 +191,11 @@ else
error('Failed to compile SQLite FTS test.')
endif
- if result.returncode() == 0
- sqlite3_has_builtin_fts5 = true
- else
- sqlite3_has_builtin_fts5 = false
+ if result.returncode() != 0
+ error('SQLite has no builtin FTS5.')
endif
endif
-if sqlite3_has_builtin_fts5
- message('Using sqlite3 builtin FTS module')
-elif sqlite.version().version_compare('>= 3.20.0')
- error('FTS support was enabled but SQLite doesn\'t have the FTS module built in')
-else
- message('sqlite3 is older than version 3.20.0, using FTS module that is bundled with Tracker')
-endif
-
##################################################################
# Check for libtracker-data and libtracker-fts: Unicode support
#
@@ -299,7 +289,6 @@ conf = configuration_data()
# Config that goes in config.h
-conf.set('HAVE_BUILTIN_FTS', sqlite3_has_builtin_fts5)
conf.set('HAVE_LIBICU', unicode_library_name == 'icu')
conf.set('HAVE_LIBSTEMMER', have_libstemmer)
conf.set('HAVE_LIBUNISTRING', unicode_library_name == 'unistring')
@@ -415,7 +404,6 @@ summary = [
' Compiler: ' + cc.get_id(),
'\nFeature Support:',
' Unicode support library: ' + unicode_library_name,
- ' Use external FTS module: ' + (not sqlite3_has_builtin_fts5).to_string(),
' Build with Stemming support: ' + have_libstemmer.to_string(),
' API documentation: ' + get_option('docs').to_string(),
' CLI documentation (manpages): ' + get_option('man').to_string(),