summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2023-05-05 21:00:12 +0000
committerDaiki Ueno <ueno@gnu.org>2023-05-05 21:00:12 +0000
commit0263dec937e02ab71fd9cb158fa69acf7c374481 (patch)
tree1e84b4e61a611894f264ceb5e9e2ef9a51dacfd0 /doc/Makefile.am
parent643342325a15e652fedac27b7bcb4614a242ab0d (diff)
parent4fe788cc172e6c06f40a42ba516a60f21369018c (diff)
downloadgnutls-master.tar.gz
Merge branch 'wip/dueno/external-psk-importer' into 'master'HEADmaster
psk: Add basic support for RFC 9258 external PSK importer interface Closes #1355 See merge request gnutls/gnutls!1741
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 6cfd6097ad..20e25dfa4e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1772,6 +1772,8 @@ FUNCS += functions/gnutls_psk_allocate_server_credentials
FUNCS += functions/gnutls_psk_allocate_server_credentials.short
FUNCS += functions/gnutls_psk_client_get_hint
FUNCS += functions/gnutls_psk_client_get_hint.short
+FUNCS += functions/gnutls_psk_format_imported_identity
+FUNCS += functions/gnutls_psk_format_imported_identity.short
FUNCS += functions/gnutls_psk_free_client_credentials
FUNCS += functions/gnutls_psk_free_client_credentials.short
FUNCS += functions/gnutls_psk_free_server_credentials
@@ -1788,6 +1790,8 @@ FUNCS += functions/gnutls_psk_set_client_credentials_function
FUNCS += functions/gnutls_psk_set_client_credentials_function.short
FUNCS += functions/gnutls_psk_set_client_credentials_function2
FUNCS += functions/gnutls_psk_set_client_credentials_function2.short
+FUNCS += functions/gnutls_psk_set_client_credentials_function3
+FUNCS += functions/gnutls_psk_set_client_credentials_function3.short
FUNCS += functions/gnutls_psk_set_params_function
FUNCS += functions/gnutls_psk_set_params_function.short
FUNCS += functions/gnutls_psk_set_server_credentials_file
@@ -1796,6 +1800,8 @@ FUNCS += functions/gnutls_psk_set_server_credentials_function
FUNCS += functions/gnutls_psk_set_server_credentials_function.short
FUNCS += functions/gnutls_psk_set_server_credentials_function2
FUNCS += functions/gnutls_psk_set_server_credentials_function2.short
+FUNCS += functions/gnutls_psk_set_server_credentials_function3
+FUNCS += functions/gnutls_psk_set_server_credentials_function3.short
FUNCS += functions/gnutls_psk_set_server_credentials_hint
FUNCS += functions/gnutls_psk_set_server_credentials_hint.short
FUNCS += functions/gnutls_psk_set_server_dh_params