summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-07-12 03:39:41 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-07-12 03:39:41 +0000
commit0bfa7d06350c225b18d790d2ff4c5fc95dddb2ab (patch)
treed29319574933ae8bf0853ee7718a869e241634f4 /Makefile.am
parent808278040bb02748165cc6d1d53b732dd7ce9872 (diff)
downloadgpsd-0bfa7d06350c225b18d790d2ff4c5fc95dddb2ab.tar.gz
Instrument the RTCM decoder so we can show that the parity computation is hosed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index cb12bf8f..976def03 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,7 @@ INCLUDES = $(DBUS_CFLAGS)
endif
bin_PROGRAMS = $(BUILD_PROGS) sirfmon
-check_PROGRAMS = gpsmm_test bits rtcmdecode
+check_PROGRAMS = gpsmm_test bits
bin_SCRIPTS = gpsprof gpsfake
#
@@ -56,12 +56,6 @@ gpsd_SOURCES = \
gpsd_LDADD = $(DBUS_LIBS) $(LIBM) libgps.la -lm $(LIBPTHREAD)
#
-# Build rtcmdecode
-#
-rtcmdecode_SOURCES = rtcmdecode,c
-rtcmdecode_CFLAGS = -O1
-
-#
# Build sirfmon
#
sirfmon_SOURCES = sirfmon.c
@@ -207,3 +201,6 @@ splint:
-splint $(sirfmon_SOURCES)
@echo "Running splint on bits test harness..."
-splint bits.c
+
+rtcmdecode: rtcmdecode.c rtcm.h
+ cc -O1 -DTESTMAIN rtcmdecode.c -o rtcmdecode