summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2010-12-03 05:10:45 -0500
committerEric S. Raymond <esr@thyrsus.com>2010-12-03 05:10:45 -0500
commit2ff0d5b686a6c669ea37870690cd5f427beb6394 (patch)
tree11ece6c69dbfa72bcf7146ebd3048ec52f6e521d /Makefile.am
parentaf7476965bde4d4564b640ef503e37553302fdf8 (diff)
downloadgpsd-2ff0d5b686a6c669ea37870690cd5f427beb6394.tar.gz
Document the deheader production.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e00dc3c4..8f529f53 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -650,12 +650,13 @@ cppcheck: gpsd.h packet_names.h
xmllint: $(XML)
for xml in $(XML); do xmllint --nonet --noout --valid $$xml; done
-# Use deheader to remove headers not required
+# Use deheader to remove headers not required. If the statistics kine
+# ends with other than '0 removed' there's work to be done.
ENABLES = -DBINARY_ENABLE -DDEBUG -DDBUS_ENABLE -DPPS_ENABLE -DRAW_ENABLE
deheader:
- make clean
+ make --quiet clean
deheader -r -i gpsd_config.h -i gpsd.h -m "MORECFLAGS='-Werror -Wfatal-errors $(ENABLES)' make -e"
- make clean
+ make --quiet clean
# Re-indent the codebase in a uniform style for readability.
INDENT_FILES = $(gpsd_c_sources) $(libgpsd_c_sources) $(libgps_c_sources) \