summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Kuethe <chris.kuethe@gmail.com>2007-01-06 03:42:25 +0000
committerChris Kuethe <chris.kuethe@gmail.com>2007-01-06 03:42:25 +0000
commite789a722f69251ce43be127200c23c0418746580 (patch)
treed03cb8ca77004a5eced24b4dc7c26f1fdf577cc4 /Makefile.am
parenta787043fa238fcf71fc84570c1a26e63d37ab1a2 (diff)
downloadgpsd-e789a722f69251ce43be127200c23c0418746580.tar.gz
Not everyone has "." in their path...
...and scripts like gpsfake won't run if you have "python2.4" but not "python". This change should allow any user to run "make gps-regress" with whatever version of python and have it just work.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 316715b4..c193f92d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -344,41 +344,41 @@ svn-tag:
# like moving between 32- and 64-bit FPUs can also break regressions.
gps-regress: gpsd
@echo "Testing the daemon..."
- @for f in test/*.log; do gpsfake -s 38400 -1 -b -p $${f} | grep -v "^GPSD,X" >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
+ @for f in test/*.log; do env PATH=".:${PATH}" $(PYTHON) gpsfake -s 38400 -1 -b -p $${f} | grep -v "^GPSD,X" >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
# Test that super-raw mode works. Compare each logfile against itself
# dumped through the daemon running in R=2 mode. (This test is not
# included in the normal regressions.)
raw-regress:
@echo "Testing super-raw mode..."
- @for f in test/*.log; do gpsfake -s 38400 -1 -b -p -r "r=2" $${f} | ./striplog -1 >test/test1.chk; ./striplog <$${f} >test/test2.chk; cmp test/test[12].chk; done; rm test/test[12].chk
+ @for f in test/*.log; do env PATH=".:${PATH}" $(PYTHON) gpsfake -s 38400 -1 -b -p -r "r=2" $${f} | ./striplog -1 >test/test1.chk; ./striplog <$${f} >test/test2.chk; cmp test/test[12].chk; done; rm test/test[12].chk
# Build the regression tests for the daemon.
gps-makeregress: gpsd
- @for f in test/*.log; do gpsfake -s 38400 -1 -b -p $${f} | grep -v "^GPSD,X" >$${f}.chk; done
+ @for f in test/*.log; do env PATH=".:${PATH}" $(PYTHON) gpsfake -s 38400 -1 -b -p $${f} | grep -v "^GPSD,X" >$${f}.chk; done
# Regression-test the RTCM decoder.
rtcm-regress: rtcmdecode
@echo "Testing RTCM decoding..."
- @for f in test/*.rtcm; do rtcmdecode <$${f} >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
+ @for f in test/*.rtcm; do ./rtcmdecode <$${f} >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
# Rebuild the RTCM regression tests.
rtcm-makeregress: rtcmdecode
- @for f in test/*.rtcm; do rtcmdecode <$${f} >$${f}.chk; done
+ @for f in test/*.rtcm; do ./rtcmdecode <$${f} >$${f}.chk; done
# Regression-test the packet getter.
packet-regress: packet_test
@echo "Testing detection of invalid packets..."
- @packet_test | diff -u test/packet.test.chk -
+ @./packet_test | diff -u test/packet.test.chk -
# Rebuild the packet-getter regression test
packet-makeregress: packet_test
- packet_test >test/packet.test.chk
+ ./packet_test >test/packet.test.chk
# Test RTCM encoding using passthrough mode.
undump-regress: rtcmdecode
@echo "Testing RTCM encoding..."
- @rtcmdecode -p <test/undump.sample >/tmp/undump.test
+ @./rtcmdecode -p <test/undump.sample >/tmp/undump.test
@diff -u test/undump.sample /tmp/undump.test
@rm /tmp/undump.test