summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-31 17:43:59 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-31 18:39:14 -0500
commit4d30dd7424161f968f79e310bf0527eca402df8b (patch)
tree83ce0ae2db6c5630fc75b1ecf62ab5b99ea371c7 /configure.ac
parent73d3c0c6f0b3c9845c3414741f6c707d93200321 (diff)
downloadgroff-git-4d30dd7424161f968f79e310bf0527eca402df8b.tar.gz
[build]: Report more configuration data.
* configure.ac: Report use of "g" prefix for commands and macro package compatibility wrappers. * m4/groff.m4 (GROFF_G): Fix code style nits. Update indentation to match recent practice.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 85dd8bc40..12cfa1be0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,7 +194,8 @@ AM_CONDITIONAL([WITHOUT_X11], [test "$groff_no_x" = yes])
# make builtin variable RM
AM_CONDITIONAL([MAKE_DONT_HAVE_RM], [test "$groff_is_rm_defined" = no])
-# Some programs have a "g" prefix if an existing groff installation is detected
+# Some programs have a "g" prefix if an existing troff installation is
+# detected.
AM_CONDITIONAL([USEPROGRAMPREFIX], [test "$g" = g])
AM_CONDITIONAL([USE_GROHTML], [test "$use_grohtml" = yes])
@@ -210,7 +211,18 @@ AC_OUTPUT
echo "
$PACKAGE_NAME version $PACKAGE_VERSION
----------------------------------------------------------------------
- installation directory prefix : $prefix
+ installation directory prefix : $prefix"
+if test -n "$g"
+then
+ echo "\
+ command name prefix : $g"
+ if test -n "$tmac_wrap"
+ then
+ echo "\
+ prefix used for macro packages : $tmac_wrap"
+ fi
+fi
+echo "\
C++ compiler and options : $CXX $CXXFLAGS $CPPFLAGS
use libgroff's memory allocator : $groff_use_own_allocator
C compiler and options : $CC $CFLAGS $CPPFLAGS