summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-20 07:52:14 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-21 11:13:08 -0500
commit6ad1adaab46968855a92465a27cc1ffc6ea6e5b3 (patch)
tree158ad89d2731ca6542e1ae730f5a9495005113a1 /configure.ac
parentb47aebc69ecd2d9855033441e9888e6d306ec904 (diff)
downloadgroff-git-6ad1adaab46968855a92465a27cc1ffc6ea6e5b3.tar.gz
[build]: Refactor libgroff allocator config.
Trivially refactor libgroff allocator configuration. * m4/groff.m4 (GROFF_USE_GROFF_ALLOCATOR): Update description of configuration flag to clarify that it's implemented in a library. Rename shell variable to prefix it with "groff_", putting it in an ad hoc name space as with other variables. If feature disabled, set variable to literal "no". * configure.ac: Use renamed variable and interpolate it directly into configuration report, simplifying shell logic. Make code style more readable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 3 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 7993558b3..9f8cce48d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,7 +198,7 @@ AM_CONDITIONAL([USEPROGRAMPREFIX], [test x$g = xg])
AM_CONDITIONAL([BUILD_HTML], [test -n "$make_htmldoc"])
AM_CONDITIONAL([BUILD_PDFDOC], [test -n "$make_pdfdoc"])
-AM_CONDITIONAL([USE_GROFF_ALLOCATOR], [test "x$use_groff_allocator" = "xyes"])
+AM_CONDITIONAL([USE_GROFF_ALLOCATOR], [test "x$groff_use_own_allocator" = "xyes"])
AM_CONDITIONAL([HAVE_PDFTOOLS], [test "x$groff_have_pdftools" = "xyes" ])
AM_CONDITIONAL([HAVE_TEXI2DVI], [test "x$groff_have_texi2dvi" = "xyes" ])
@@ -210,15 +210,8 @@ echo "
${PACKAGE_NAME} version ${PACKAGE_VERSION}
----------------------------------------------------------------------
installation prefix : ${prefix}
- C++ compiler : ${CXX} ${CXXFLAGS} ${CPPFLAGS}"
-if test "x$use_groff_allocator" = "xyes"; then
-echo "\
- use libgroff's memory allocator : yes"
-else
-echo "\
- use libgroff's memory allocator : no"
-fi
-echo "\
+ C++ compiler : ${CXX} ${CXXFLAGS} ${CPPFLAGS}
+ use libgroff's memory allocator : $groff_use_own_allocator
C compiler : ${CC} ${CFLAGS} ${CPPFLAGS}
Perl interpreter version : $perl_version"
if test "x$groff_no_x" = "xyes"; then