summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-20 15:16:44 -0500
committerG. Branden Robinson <g.branden.robinson@gmail.com>2022-05-21 11:13:08 -0500
commit72d251b9c58e5a5211ff72e05b064604c347646e (patch)
tree048a104cdebb4f535f806b5465690a9fb6c56c20 /configure.ac
parentaa5787c1eb1b388ab246a02cdbf2d9267e701494 (diff)
downloadgroff-git-72d251b9c58e5a5211ff72e05b064604c347646e.tar.gz
[build]: Refactor gropdf runtime-dep check.
Handle missing programs required to construct files needed at runtime by gropdf more gracefully. Rename and refactor configuration-time logic to be more understandable. * configure.ac: * m4/groff.m4: Rename `GROFF_PDFDOC_PROGRAMS` macro to `GROFF_CHECK_GROPDF_PROGRAMS`. Rename shell variable `make_pdfdoc` to `use_gropdf`. Set it explicitly to "no" or "yes" instead of null or not null. * configure.ac: * m4/groff.m4: * doc/doc.am: * contrib/mom/mom.am: * contrib/pdfmark/pdfmark.am: * contrib/sboxes/sboxes.am: Rename `BUILD_PDFDOC` to `USE_GROPDF`. * configure.ac: Call `GROFF_GROPDF_PROGRAM_NOTICE`. * doc/doc.am: Bracket definition of `PROCESSEDDOCFILES_PDF` macro and `$(PROCESSEDDOCFILES_PDF)` dependency declaration in Automake `if USE_GROPDF` conditional. This prevents attempts to build PDF documents using groff that are doomed to fail. * m4/groff.m4: Refactor gropdf runtime-dependency program check. Split into two macros: one (`GROFF_CHECK_GROPDF_PROGRAMS`) performs the check, the other (`GROFF_GROPDF_PROGRAM_NOTICE`) issues a notice at the end of the configuration process if at least one program was not found. Rename `docnote` shell variable to `gropdf_notice`. Tighten wording of notice. Drop unused `make_install_pdfdoc` and `make_uninstall_pdfdoc` shell variables. Also make code style more readable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index de79302a9..3a878b688 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,7 +164,7 @@ GROFF_TMAC
GROFF_WITH_COMPATIBILITY_WRAPPERS
GROFF_TARGET_PATH_SEPARATOR
GROFF_CHECK_GROHTML_PROGRAMS
-GROFF_PDFDOC_PROGRAMS
+GROFF_CHECK_GROPDF_PROGRAMS
GROFF_PNMTOOLS_CAN_BE_QUIET
GROFF_PNMTOPS_NOSETPAGE
GROFF_MAKE_RM
@@ -198,7 +198,7 @@ AM_CONDITIONAL([MAKE_DONT_HAVE_RM], [test "$groff_is_rm_defined" = no])
AM_CONDITIONAL([USEPROGRAMPREFIX], [test "$g" = g])
AM_CONDITIONAL([USE_GROHTML], [test "$use_grohtml" = yes])
-AM_CONDITIONAL([BUILD_PDFDOC], [test -n "$make_pdfdoc"])
+AM_CONDITIONAL([USE_GROPDF], [test "$use_gropdf" = yes])
AM_CONDITIONAL([USE_GROFF_ALLOCATOR], [test "$groff_use_own_allocator" = yes])
AM_CONDITIONAL([HAVE_PDFTOOLS], [test "$groff_have_pdftools" = yes ])
AM_CONDITIONAL([HAVE_TEXI2DVI], [test "$groff_have_texi2dvi" = yes ])
@@ -236,3 +236,4 @@ GROFF_URW_FONTS_CHECK
GROFF_UCHARDET_CHECK
GROFF_GHOSTSCRIPT_VERSION_NOTICE
GROFF_GROHTML_PROGRAM_NOTICE
+GROFF_GROPDF_PROGRAM_NOTICE