summaryrefslogtreecommitdiff
path: root/ext/closedcaption/meson.build
diff options
context:
space:
mode:
authorEdward Hervey <edward@centricular.com>2015-03-11 18:00:08 +0800
committerEdward Hervey <bilboed@bilboed.com>2018-05-28 15:29:01 +0200
commita41fb3c6df9ff124d1d04f414c2e122bd7dea37c (patch)
tree23ed2a7eb78c1f2caf6b7375e74bdaa7292d676a /ext/closedcaption/meson.build
parentaab111b9791ced63de6b324d902f99ca518d3edd (diff)
downloadgstreamer-plugins-bad-a41fb3c6df9ff124d1d04f414c2e122bd7dea37c.tar.gz
ceaccoverlay: New CEA-708 Closed Caption decoder and overlayer
This new element allows decoding and overlaying CEA-708 Closed Caption streams over video. * Supports CDP and cc_data closedcaption/x-cea-708 streams * Uses pango to render CC stream * Support GstVideoOverlayComposition meta if downstream supports is Tested on various test files. Remains to be fixed/improved: * Switch to GstByteReader (for code safety) * Switch to GString (instead of manual pango string construction) * Move pango/rendering code outside of main 708 decoder file (so that actual CC parser/decoder can be (re)used in other scenarios). Initial patches and improvements by: * CableLabs RUIH-RI Team <ruihri@cablelabs.com> * Steve Maynard <steve@secondstryke.com> * cjun.wang" <cjun.wang@samsung.com> https://bugzilla.gnome.org/show_bug.cgi?id=704881
Diffstat (limited to 'ext/closedcaption/meson.build')
-rw-r--r--ext/closedcaption/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/ext/closedcaption/meson.build b/ext/closedcaption/meson.build
index 841fab751..4e1ed3a37 100644
--- a/ext/closedcaption/meson.build
+++ b/ext/closedcaption/meson.build
@@ -9,7 +9,8 @@ zvbi_sources = [
if pangocairo_dep.found()
gstclosedcaption = library('gstclosedcaption',
- 'gstccextractor.c', 'gstclosedcaption.c', 'gstline21dec.c', zvbi_sources,
+ 'gstccextractor.c', 'gstclosedcaption.c', 'gstline21dec.c',
+ 'gstcea708decoder.c', 'gstceaccoverlay.c', zvbi_sources,
c_args : gst_plugins_bad_args,
link_args : noseh_link_args,
include_directories : [configinc],