summaryrefslogtreecommitdiff
path: root/gst/mpegtsdemux/Makefile.am
diff options
context:
space:
mode:
authorJanne Grunau <janne.grunau@collabora.co.uk>2011-02-16 17:57:42 +0100
committerEdward Hervey <bilboed@bilboed.com>2011-02-17 17:56:59 +0100
commit22ecf13e428d05ca55b76a930c62e8cf91a075d4 (patch)
treeb65ff6c869eefc4a8250ddce769788c964bf41fb /gst/mpegtsdemux/Makefile.am
parent2bb835f69af69c98d31f857456211fd05d5e5251 (diff)
downloadgstreamer-plugins-bad-22ecf13e428d05ca55b76a930c62e8cf91a075d4.tar.gz
mpegtsdemux: add MPEG TS demuxer rewrite from Edward Hervey
with contributions from Miquel Angel Farre Guiu and Zaheer Abbas Merali
Diffstat (limited to 'gst/mpegtsdemux/Makefile.am')
-rw-r--r--gst/mpegtsdemux/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/gst/mpegtsdemux/Makefile.am b/gst/mpegtsdemux/Makefile.am
new file mode 100644
index 000000000..bb88bbdd8
--- /dev/null
+++ b/gst/mpegtsdemux/Makefile.am
@@ -0,0 +1,27 @@
+plugin_LTLIBRARIES = libgstmpegtsdemux.la
+
+libgstmpegtsdemux_la_SOURCES = \
+ gsttsdemux.c \
+ gstmpegdesc.c \
+ mpegtsbase.c \
+ mpegtspacketizer.c \
+ mpegtsparse.c \
+ tsdemux.c
+
+libgstmpegtsdemux_la_CFLAGS = \
+ $(GST_PLUGINS_BAD_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstmpegtsdemux_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgsttag-$(GST_MAJORMINOR) \
+ $(GST_BASE_LIBS) $(GST_LIBS)
+libgstmpegtsdemux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstmpegtsdemux_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = \
+ gstmpegdefs.h \
+ gstmpegdesc.h \
+ mpegtsbase.h \
+ mpegtspacketizer.h \
+ mpegtsparse.c \
+ tsdemux.h
+