summaryrefslogtreecommitdiff
path: root/gst/mpegtsdemux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/mpegtsdemux/Makefile.am')
-rw-r--r--gst/mpegtsdemux/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/gst/mpegtsdemux/Makefile.am b/gst/mpegtsdemux/Makefile.am
new file mode 100644
index 000000000..bb88bbdd8
--- /dev/null
+++ b/gst/mpegtsdemux/Makefile.am
@@ -0,0 +1,27 @@
+plugin_LTLIBRARIES = libgstmpegtsdemux.la
+
+libgstmpegtsdemux_la_SOURCES = \
+ gsttsdemux.c \
+ gstmpegdesc.c \
+ mpegtsbase.c \
+ mpegtspacketizer.c \
+ mpegtsparse.c \
+ tsdemux.c
+
+libgstmpegtsdemux_la_CFLAGS = \
+ $(GST_PLUGINS_BAD_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstmpegtsdemux_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgsttag-$(GST_MAJORMINOR) \
+ $(GST_BASE_LIBS) $(GST_LIBS)
+libgstmpegtsdemux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstmpegtsdemux_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = \
+ gstmpegdefs.h \
+ gstmpegdesc.h \
+ mpegtsbase.h \
+ mpegtspacketizer.h \
+ mpegtsparse.c \
+ tsdemux.h
+