summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-12-18 21:16:43 +0900
committerTim-Philipp Müller <tim@centricular.com>2018-12-18 16:48:17 +0000
commit1b0b2c37cc0178d8103e303110f5764b4d6b3a83 (patch)
tree52ae3338a7df136eb15682d684163d876b04bc53 /meson.build
parentf74ad82ddcef0f18a43989aab25ee6d9fa37b98e (diff)
downloadgstreamer-plugins-bad-1b0b2c37cc0178d8103e303110f5764b4d6b3a83.tar.gz
meson: Prefer to use join_paths() over '/'
... to avoid mixing '/' and '\' in a path string on Windows.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index bd9dac735..12f6dbee7 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,7 @@ curversion = gst_version_minor * 100 + gst_version_micro
libversion = '@0@.@1@.0'.format(soversion, curversion)
osxversion = curversion + 1
-plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
+plugins_install_dir = join_paths(get_option('libdir'), 'gstreamer-1.0')
cc = meson.get_compiler('c')
cxx = meson.get_compiler('cpp')