summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2019-03-23 18:58:06 +0000
committerTim-Philipp Müller <tim@centricular.com>2019-03-23 18:58:06 +0000
commit35cdefe2e05a6760aef366fcb1acaf9ca043982a (patch)
tree4dd77db5624b2c525c131a2037557007b0b45fbe /meson.build
parentcacd51fa9336e6e606f340b48e01a66034bea0ee (diff)
downloadgstreamer-plugins-bad-35cdefe2e05a6760aef366fcb1acaf9ca043982a.tar.gz
g-i: pass --quiet to g-ir-scanner
This suppresses the annoying 'g-ir-scanner: link: cc ..' output that we get even if everything works just fine. We still get g-ir-scanner warnings and compiler warnings if we pass this option.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3c10943c0..c2f71edbf 100644
--- a/meson.build
+++ b/meson.build
@@ -410,7 +410,7 @@ gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' +
'g_setenv("GST_REGISTRY_1.0", "@0@", TRUE);'.format(meson.current_build_dir() + '/gir_empty_registry.reg') + \
'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \
'g_setenv("GST_PLUGIN_SYSTEM_PATH_1_0", "", TRUE);' + \
- 'gst_init(NULL,NULL);' ]
+ 'gst_init(NULL,NULL);', '--quiet']
presetdir = join_paths(get_option('datadir'), 'gstreamer-' + api_version, 'presets')