summaryrefslogtreecommitdiff
path: root/tests/testtooltips.c
Commit message (Collapse)AuthorAgeFilesLines
* tests: Stop using gtk_widget_show/hideMatthias Clasen2022-12-131-1/+1
|
* tests: Ignore deprecationsMatthias Clasen2022-10-111-0/+2
| | | | Eventually, most of these tests should be dropped.
* Remove pointless inout argumentsebassi/inout-argsEmmanuele Bassi2020-11-171-1/+1
| | | | | | | | | | | | | | | | GtkTreeView.get_tooltip_context() takes an inout X and Y coordinates, but the "out" side is a side effect: the conversion from widget-relative to bin window-relative coordinates is not documented, and can be done using public API, if needed. GtkIconView.get_tooltip_context() follows the same pattern, and takes two inout arguments for the coordinates, but it does not change them any more, after GtkIconView's bin window was dropped in commit 8dc5e13e. There's really no point in having these `inout` arguments, and while GtkTreeView and GtkIconView are certainly de-emphasised in GTK4, and we nudge developers to move to the new list views, we should take advantage of the API break to remove warts.
* Clean up lots of GTK+ -> GTKMatthias Clasen2020-09-121-1/+1
| | | | | | Replace most remaining uses of GTK+ in the docs and user-visible strings by GTK. Also remove some leftover "Was added in 3.x" sentences from the docs.
* Replace "gfloat" with "float"Benjamin Otte2020-07-251-3/+3
|
* Replace "gchar" with "char"Benjamin Otte2020-07-251-2/+2
|
* Replace "gint" with "int"Benjamin Otte2020-07-251-16/+16
|
* Make tooltip properties idiomaticEmmanuele Bassi2020-06-051-10/+7
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The tooltip handling in GtkWidget is "special": - the string is stored inside the qdata instead of the private instance data - the accessors call g_object_set() and g_object_get(), and the logic is all inside the property implementation, instead of being the other way around - the getters return a copy of the string - the setters don't really notify all the involved properties The GtkWidgetAccessible uses the (escaped) tooltip text as a source for the accessible object description, which means it has to store the tooltip inside the object qdata, and update its copy at construction and property notification time. We can simplify this whole circus by making the tooltip properties (text and markup) more idiomatic: - notify all side-effect properties - return a constant string from the getter - if tooltip-text is set: - store the text as is - escape the markup and store it separately for the markup getter - if tooltip-markup is set: - store the markup as is - parse the markup and store it separately for the text getter The part of the testtooltips interactive test that checks that the getters are doing the right thing is now part of the gtk testsuite, so we ensure we don't regress in behaviour.
* Replace most remaining uses of container apiMatthias Clasen2020-05-111-16/+16
| | | | These are all on GtkBox or enumerating children.
* testtooltips: Derive demo from GtkWidgetMatthias Clasen2020-05-041-4/+5
|
* Use gtk_window_set_child throughoutMatthias Clasen2020-05-041-1/+1
| | | | | Replace all uses of gtk_container_add on windows by gtk_window_set_child.
* Use gtk_popover_set_child throughoutMatthias Clasen2020-05-041-1/+1
| | | | | Replace all uses of gtk_container_add on popovers by gtk_popover_set_child.
* Use gtk_widget_add/remove_css_class moreMatthias Clasen2020-04-101-1/+1
| | | | | | Replace most uses of gtk_style_context_add/remove_class by the new APIs. The only remaining uses of the old API are in save/restore situations.
* tests: Add common_cflags to buildTimm Bäder2020-03-061-0/+1
| | | | | | And fix all the errors and warnings resulting from that See #2491
* Merge branch 'spinning-spinner' into 'master'Matthias Clasen2020-02-251-2/+2
|\ | | | | | | | | Rename GtkSpinner::active to ::spinning See merge request GNOME/gtk!1475
| * Rename GtkSpinner::active to ::spinningMatthias Clasen2020-02-241-2/+2
| | | | | | | | | | | | And add a setter and getter. The old name was confusing with the widget state of the same name. 'Active' is just too overloaded.
* | popover: Drop ::relative-toMatthias Clasen2020-02-241-1/+1
|/ | | | | | | | | It is enough to just set the parent (and make the parent call gtk_native_check_resize in size_allocate). This commit removes the relative_to argument to the constructors of GtkPopover and GtkPopoverMenu, and updates all callers.
* window: Remove type argument from gtk_window_new()Benjamin Otte2020-02-141-1/+1
|
* Stop using gtk_main and gtk_main_quitMatthias Clasen2020-02-091-2/+15
| | | | Replace these calls with direct use of GMainContext api.
* testtooltips: Test tooltips on popoversMatthias Clasen2019-12-291-43/+25
| | | | They do not currently work right.
* Stop using gtk_box_pack_endTimm Bäder2019-01-231-11/+11
| | | | It might soon go away!
* GdkWindow -> GdkSurface initial type renameAlexander Larsson2018-03-201-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This renames the GdkWindow class and related classes (impl, backend subclasses) to surface. Additionally it renames related types: GdkWindowAttr, GdkWindowPaint, GdkWindowWindowClass, GdkWindowType, GdkWindowTypeHint, GdkWindowHints, GdkWindowState, GdkWindowEdge This is an automatic conversion using the below commands: git sed -f g GdkWindowWindowClass GdkSurfaceSurfaceClass git sed -f g GdkWindow GdkSurface git sed -f g "gdk_window\([ _\(\),;]\|$\)" "gdk_surface\1" # Avoid hitting gdk_windowing git sed -f g "GDK_WINDOW\([ _\(]\|$\)" "GDK_SURFACE\1" # Avoid hitting GDK_WINDOWING git sed "GDK_\([A-Z]*\)IS_WINDOW\([_ (]\|$\)" "GDK_\1IS_SURFACE\2" git sed GDK_TYPE_WINDOW GDK_TYPE_SURFACE git sed -f g GdkPointerWindowInfo GdkPointerSurfaceInfo git sed -f g "BROADWAY_WINDOW" "BROADWAY_SURFACE" git sed -f g "broadway_window" "broadway_surface" git sed -f g "BroadwayWindow" "BroadwaySurface" git sed -f g "WAYLAND_WINDOW" "WAYLAND_SURFACE" git sed -f g "wayland_window" "wayland_surface" git sed -f g "WaylandWindow" "WaylandSurface" git sed -f g "X11_WINDOW" "X11_SURFACE" git sed -f g "x11_window" "x11_surface" git sed -f g "X11Window" "X11Surface" git sed -f g "WIN32_WINDOW" "WIN32_SURFACE" git sed -f g "win32_window" "win32_surface" git sed -f g "Win32Window" "Win32Surface" git sed -f g "QUARTZ_WINDOW" "QUARTZ_SURFACE" git sed -f g "quartz_window" "quartz_surface" git sed -f g "QuartzWindow" "QuartzSurface" git checkout NEWS* po-properties
* Replace all remaining uses of delete-eventMatthias Clasen2018-01-161-2/+1
|
* tooltips: Remove GtkIconSize usageBenjamin Otte2017-11-151-2/+1
|
* testtooltips: Add static tooltipTimm Bäder2017-07-191-0/+40
| | | | | Just a widget class emulating the tooltip look by calling itself "tooltip" in the css node tree and adding the .background style class.
* box: Remove fill child propertyTimm Bäder2017-04-251-11/+11
| | | | GtkWidget:halign and GtkWidget:valign are sufficient
* box: Remove expand child propertyTimm Bäder2017-04-251-11/+11
| | | | GtkWidget already has hexpand/vexpand properties.
* Remove gtk_widget_show_allTimm Bäder2017-01-201-1/+1
|
* Update callersMatthias Clasen2017-01-191-1/+1
| | | | Adapt all our tests and examples to the new initialization api.
* tests: Make testtooltips not use the draw signalBenjamin Otte2016-11-181-24/+10
|
* widget: Remove app-paintableTimm Bäder2016-10-311-1/+0
|
* API: container: Remove gtk_container_set_border_width()Benjamin Otte2016-10-161-1/+0
|
* box: Remove 'padding' child propertyTimm Bäder2016-10-161-11/+11
|
* wayland: fix testtooltipsOlivier Fourdan2015-12-041-0/+5
| | | | | | | | | | On Wayland, for tooltips to work as expected, the type hint must be set to tooltips, otherwise the popup window won't be translated as a subsurface. Fix the test do work as expected under Wayland. Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=759018
* tests: Update testtooltips for deprecationsBenjamin Otte2014-10-121-2/+13
|
* Remove most of the stock API usage from the testsWilliam Jon McCann2013-06-241-2/+2
| | | | With the exception of GtkActions and the tests for stock items.
* Removed all variables from GtkTreeViewColumn and created ↵Tristan Van Berkom2010-12-051-1/+1
| | | | | | | | | GtkTreeViewColumnPrivate Some details: - button_request was not needed, consult the minimum request of the button - gtk_tree_view_column_get_button() needed to be public as people can set tooltips on the button (and libgail accesses the button).
* Make tests compile without using GtkStyle apiMatthias Clasen2010-12-041-2/+2
|
* gtk: remove "gboolean homogeneous" from gtk_box_new()Michael Natterer2010-10-311-1/+1
| | | | Because it's FALSE in virtually all use cases.
* Use gtk_box_new() instead gtk_[v|h]box_new()Javier Jardón2010-10-301-1/+1
|
* testtooltips: Connect to draw signalBenjamin Otte2010-09-261-17/+6
|
* testtooltips: Don't call gdk_window_get_pointer() in expose eventsBenjamin Otte2010-09-261-2/+0
|
* tests/testtooltips.c: Use accessor functions to access GtkWidgetJavier Jardón2010-08-221-5/+8
|
* Move sealed attributes to private struct.Ignacio Casal Quinteiro2010-07-121-2/+3
|
* Add code to test gtk_tooltip_set_custom()Matthias Clasen2007-07-241-0/+32
| | | | | | | | | | 2007-07-23 Matthias Clasen <mclasen@redhat.com> * tests/testtooltips.c: Add code to test gtk_tooltip_set_custom() svn path=/trunk/; revision=18533
* Remove obsolete code. Bug #459566.Christian Persch2007-07-231-21/+0
| | | | | | | | | 2007-07-23 Christian Persch <chpe@gnome.org> * tests/testtooltips.c: (query_tooltip_tree_view_cb): Remove obsolete code. Bug #459566. svn path=/trunk/; revision=18531
* add more convenience API.Kristian Rietveld2007-07-191-1/+5
| | | | | | | | | | | | | | | | | | 2007-07-19 Kristian Rietveld <kris@imendio.com> * gtk/gtk.symbols: * gtk/gtktreeprivate.h: * gtk/gtktreeview.[ch] (gtk_tree_view_get_tooltip_context), (gtk_tree_view_[sg]et_tooltip_column): add more convenience API. * tests/testtooltip.c (query_tooltip_tree_view_cb): use gtk_tree_view_get_tooltip_context(). * demos/gtk-demo/demo.ui: add a tooltip column to the list store, set tooltip-column on the tree view. svn path=/trunk/; revision=18496
* #408327, improve tooltip positioning.Kristian Rietveld2007-07-131-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | | 2007-07-13 Kristian Rietveld <kris@imendio.com> #408327, improve tooltip positioning. * gtk/gtk.symbols: updated. * gtk/gtktooltip.[ch] (gtk_tooltip_position): factor out positioning code in here, (gtk_tooltip_set_tip_area): new function to set the tooltip area, (gtk_tooltip_reset), (_gtk_tooltip_handle_event): hide tooltip once the pointer leaves the tip area. * gtk/gtktreeview.[ch] (gtk_tree_view_set_tooltip_row), (gtk_tree_view_set_tooltip_cell): convenience functions to set tip area for row/column/cell. * tests/testtooltips.c (query_tooltip_tree_view_cb): use gtk_tree_view_set_tooltip_row. svn path=/trunk/; revision=18464
* Improving handling of tooltip-text property. Also check result of tooltipMathias Hasselmann2007-06-151-0/+20
| | | | | | | | | 2007-06-15 Mathias Hasselmann <mathias.hasselmann@gmx.de> * gtk/gtkwidget.c: Improving handling of tooltip-text property. * tests/testtooltips.c: Also check result of tooltip getters. svn path=/trunk/; revision=18143
* Introduce convenience property "GtkWidget:tooltip-text" taking care ofMathias Hasselmann2007-06-151-6/+6
| | | | | | | | | | | | | | | | | | 2007-06-15 Mathias Hasselmann <mathias.hasselmann@gmx.de> * docs/reference/gtk/gtk-sections.txt, gtk/gtk.symbols, gtk/gtkwidget.c, gtk/gtkwidget.h, tests/testtooltips.c: Introduce convenience property "GtkWidget:tooltip-text" taking care of escaping it for unwanted markup entities. Add functions to set tooltip text: gtk_widget_set_tooltip_text(), gtk_widget_set_tooltip_markup(), gtk_widget_get_tooltip_text(), gtk_widget_get_tooltip_markup(). * gtk/gtktooltip.c, gtk/gtktooltip.h: Add gtk_tooltip_set_text() to set the tooltip text without using markup. Patches from Emmanuele Bassi (#447643). svn path=/trunk/; revision=18142