summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-01-19 00:32:12 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-19 00:32:12 +0100
commit3bb08542d297980ea8ca9403e71d2fcd640c4877 (patch)
tree9d844e98ae86f2a14210a6d6775a9636032a044e /lib/Makefile.am
parentd98888290b243e1c98ac7afb085a0925a33c8615 (diff)
downloadguile-3bb08542d297980ea8ca9403e71d2fcd640c4877.tar.gz
Add Gnulib modules for 'posix_spawn' file operations.
This is again from Gnulib v0.1-5703-g356a414e8c. * m4/gnulib-cache.m4: Add 'posix_spawn_file_actions_addclose', 'posix_spawn_file_actions_adddup2', 'posix_spawn_file_actions_addopen', and 'posix_spawn_file_actions_init'.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index c3223052f..eddfa7282 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -111,6 +111,10 @@
# pipe2 \
# poll \
# posix_spawn \
+# posix_spawn_file_actions_addclose \
+# posix_spawn_file_actions_adddup2 \
+# posix_spawn_file_actions_addopen \
+# posix_spawn_file_actions_init \
# posix_spawnp \
# putenv \
# readlink \
@@ -2068,6 +2072,46 @@ EXTRA_DIST += spawn_int.h
## end gnulib module posix_spawn-internal
+## begin gnulib module posix_spawn_file_actions_addclose
+
+if GL_COND_OBJ_SPAWN_FACTION_ADDCLOSE
+libgnu_la_SOURCES += spawn_faction_addclose.c
+endif
+
+EXTRA_DIST += spawn_int.h
+
+## end gnulib module posix_spawn_file_actions_addclose
+
+## begin gnulib module posix_spawn_file_actions_adddup2
+
+if GL_COND_OBJ_SPAWN_FACTION_ADDDUP2
+libgnu_la_SOURCES += spawn_faction_adddup2.c
+endif
+
+EXTRA_DIST += spawn_int.h
+
+## end gnulib module posix_spawn_file_actions_adddup2
+
+## begin gnulib module posix_spawn_file_actions_addopen
+
+if GL_COND_OBJ_SPAWN_FACTION_ADDOPEN
+libgnu_la_SOURCES += spawn_faction_addopen.c
+endif
+
+EXTRA_DIST += spawn_int.h
+
+## end gnulib module posix_spawn_file_actions_addopen
+
+## begin gnulib module posix_spawn_file_actions_init
+
+if GL_COND_OBJ_SPAWN_FACTION_INIT
+libgnu_la_SOURCES += spawn_faction_init.c
+endif
+
+EXTRA_DIST += spawn_int.h
+
+## end gnulib module posix_spawn_file_actions_init
+
## begin gnulib module posix_spawnp
if GL_COND_OBJ_SPAWNP