summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index c3223052f..eddfa7282 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -111,6 +111,10 @@
# pipe2 \
# poll \
# posix_spawn \
+# posix_spawn_file_actions_addclose \
+# posix_spawn_file_actions_adddup2 \
+# posix_spawn_file_actions_addopen \
+# posix_spawn_file_actions_init \
# posix_spawnp \
# putenv \
# readlink \
@@ -2068,6 +2072,46 @@ EXTRA_DIST += spawn_int.h
## end gnulib module posix_spawn-internal
+## begin gnulib module posix_spawn_file_actions_addclose
+
+if GL_COND_OBJ_SPAWN_FACTION_ADDCLOSE
+libgnu_la_SOURCES += spawn_faction_addclose.c
+endif
+
+EXTRA_DIST += spawn_int.h
+
+## end gnulib module posix_spawn_file_actions_addclose
+
+## begin gnulib module posix_spawn_file_actions_adddup2
+
+if GL_COND_OBJ_SPAWN_FACTION_ADDDUP2
+libgnu_la_SOURCES += spawn_faction_adddup2.c
+endif
+
+EXTRA_DIST += spawn_int.h
+
+## end gnulib module posix_spawn_file_actions_adddup2
+
+## begin gnulib module posix_spawn_file_actions_addopen
+
+if GL_COND_OBJ_SPAWN_FACTION_ADDOPEN
+libgnu_la_SOURCES += spawn_faction_addopen.c
+endif
+
+EXTRA_DIST += spawn_int.h
+
+## end gnulib module posix_spawn_file_actions_addopen
+
+## begin gnulib module posix_spawn_file_actions_init
+
+if GL_COND_OBJ_SPAWN_FACTION_INIT
+libgnu_la_SOURCES += spawn_faction_init.c
+endif
+
+EXTRA_DIST += spawn_int.h
+
+## end gnulib module posix_spawn_file_actions_init
+
## begin gnulib module posix_spawnp
if GL_COND_OBJ_SPAWNP