summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-05-17 13:02:49 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-05-17 13:02:49 -0700
commit77cadcef6ea687e7181aa222c47402f34644a6ea (patch)
treeb6eaf42ae39b3694b445322595fbb26611ef2e02 /Makefile.am
parent2afbb4393b1053fcb2edbec7c92575245efabffe (diff)
downloadiceauth-77cadcef6ea687e7181aa222c47402f34644a6ea.tar.gz
Add option to check code with lint/sparse/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b1838be..d5692d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,3 +72,10 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(iceauth_CFLAGS)
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(iceauth_SOURCES)
+endif LINT