summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2016-10-06 14:56:49 +0200
committerFrancis Dupont <fdupont@isc.org>2016-10-06 14:56:49 +0200
commit13e5cc6cbe83ac7cd9285a54e870e4f8ab16a604 (patch)
tree8176d5eaddb7cd24e9e291db11c2cf433a25a170 /configure.ac
parent3a4fc3841ea817c848e5a231b9e5c8f5c9895e6d (diff)
downloadisc-dhcp-13e5cc6cbe83ac7cd9285a54e870e4f8ab16a604.tar.gz
Libtoolize build chain (unfinished)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 41 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7f199a84..338879b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,9 @@
AC_INIT([DHCP],[4.4.0-dev],[dhcp-users@isc.org])
+
# we specify "foreign" to avoid having to have the GNU mandated files,
# like AUTHORS, COPYING, and such
-AM_INIT_AUTOMAKE([foreign])
+AM_INIT_AUTOMAKE([foreign subdir-objects])
# we specify AM_MAINTAINER_MODE to avoid problems with rebuilding
# the configure and makefiles. Without it users doing things that
@@ -805,6 +806,40 @@ if test "$enable_bind_install" = "yes" -a "$use_libbind" != "no"; then
fi
AM_CONDITIONAL(INSTALL_BIND, test "$enable_bind_install" = "yes")
+#
+# GNU libtool support
+#
+case "$build_os" in
+ sunos*)
+ # Just set the maximum command line length for sunos
+ # as it otherwise takes a exceptionally long time to
+ # work it out. Required for libtool.
+
+ lt_cv_sys_max_cmd_len=4096
+ ;;
+esac
+
+want_libtool="no"
+
+BINDLT=
+AC_ARG_ENABLE(libtool,
+ AS_HELP_STRING([--enable-libtool],[use GNU libtool for dynamic shared libraries (default is $default_libtool).]),
+ want_libtool="$enableval")
+if test "$want_libtool" = "yes"; then
+if test "$want_libtool" = "yes"; then
+ AC_MSG_WARN([legacy configure is used but libtool is enabled. Trying to recover...])
+ AC_MSG_WARN([legacy configure is used but libtool is enabled. Trying to recover...])
+ cd $srcdir; exec ./re-conf $ac_configure_args
+ cd $srcdir; exec ./re-conf $ac_configure_args
+ AC_MSG_ERROR([Recovering failed])
+ AC_MSG_ERROR([Recovering failed])
+fi
+fi
+A=a
+A=a
+AC_SUBST(A)
+AC_SUBST(BINDLT)
+
# OpenLDAP support.
AC_ARG_WITH(ldap,
AS_HELP_STRING([--with-ldap],[enable OpenLDAP support in dhcpd (default is no)]),
@@ -900,13 +935,17 @@ AC_CONFIG_FILES([
Makefile
client/Makefile
client/tests/Makefile
+ common/Makefile.am
common/Makefile
common/tests/Makefile
+ dhcpctl/Makefile.am
dhcpctl/Makefile
includes/Makefile
+ omapip/Makefile.am
omapip/Makefile
relay/Makefile
server/Makefile
+ tests/Makefile.am
tests/Makefile
tests/unittest.sh
server/tests/Makefile
@@ -914,6 +953,7 @@ AC_CONFIG_FILES([
])
AC_OUTPUT
+
if test "$enable_dhcpv4o6" = "yes"; then
DHCP_VERSIONS="DHCPv4, DHCPv6 and DHCPv4-over-DHCPv6"
elif test "$enable_dhcpv6" != "no"; then