summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Matuška <martin@matuska.org>2020-04-24 03:47:05 +0200
committerGitHub <noreply@github.com>2020-04-24 03:47:05 +0200
commit4a6e98919923c2d8e426d3103c5014aeb1c213f0 (patch)
treeea617355368cf19e8a18889aa73be70e125db784 /CMakeLists.txt
parent8960e4ffa718b399fb23178d5bd389fa56685720 (diff)
parent2836d83c06af0cc3168889bcc2f71f791726ae36 (diff)
downloadlibarchive-4a6e98919923c2d8e426d3103c5014aeb1c213f0.tar.gz
Merge pull request #1364 from aseprite/macos-no-deprecated
Disable error using deprecated functions on macOS 10.15 to calculate MD5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d9481747..57b8e5b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2036,6 +2036,11 @@ IF(MSVC)
ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
ENDIF(MSVC)
+IF(APPLE)
+ # CC_MD5_Init() functions are deprecated on macOS 10.15, but we want to use them
+ ADD_DEFINITIONS(-Wno-deprecated-declarations)
+ENDIF(APPLE)
+
IF(ENABLE_TEST)
ADD_CUSTOM_TARGET(run_all_tests)
ENDIF(ENABLE_TEST)