summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-02-23 14:55:57 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-02-23 14:55:57 +0000
commitf8a7661f2a63c9ffe86151439b4243836c5cb82a (patch)
tree4c9e11a9cb8087d9b97180c6b357ca65e71254c2 /meson.build
parenta57fb0b171b47f0168709ee8c0194577144d599e (diff)
downloadlibepoxy-f8a7661f2a63c9ffe86151439b4243836c5cb82a.tar.gz
meson: Remove unnecessary configuration_data object
We generate the pkg-config file using Meson's pkgconfig module as of commit b1119d8fcfe646f3ff108a3bf3685dfce6f049e4, but we're still setting up a configuration_data object.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 0 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 0f6dc71..026d359 100644
--- a/meson.build
+++ b/meson.build
@@ -217,20 +217,6 @@ if host_system == 'windows'
gdi32_dep = cc.find_library('gdi32', required: true)
endif
-# PkgConfig file
-pkgconf = configuration_data()
-pkgconf.set('prefix', epoxy_prefix)
-pkgconf.set('exec_prefix', epoxy_prefix)
-pkgconf.set('libdir', epoxy_libdir)
-pkgconf.set('includedir', epoxy_includedir)
-pkgconf.set10('epoxy_has_glx', build_glx)
-pkgconf.set10('epoxy_has_egl', build_egl)
-pkgconf.set10('epoxy_has_wgl', build_wgl)
-pkgconf.set('PACKAGE_VERSION', meson.project_version())
-if dl_dep.found()
- pkgconf.set('DLOPEN_LIBS', '-ldl')
-endif
-
# Python
python = import('python3').find_python()
if not python.found()