summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-06-29 20:34:53 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-06-29 21:42:09 -0700
commitf101b311bee3b18c5340e99d1fd7f199cba59bfe (patch)
treee49191992a6765378312d25ef42fc87529aade82 /Makefile.am
parent9008d7d7ac058cc5dc7177f10ecaf9e3db945b4c (diff)
downloadliberasurecode-f101b311bee3b18c5340e99d1fd7f199cba59bfe.tar.gz
autoconf: Tell libtool about libXorcore version
Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ce71d88..39d211a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,9 @@ libXorcode_la_SOURCES = \
src/builtin/xor_codes/xor_code.c \
src/builtin/xor_codes/xor_hd_code.c
+# Version format (C - A).(A).(R) for C:R:A input
+libXorcode_la_LDFLAGS = -rpath '$(libdir)' -version-info 1:1:0
+
liberasurecode_la_SOURCES = \
src/main.c \
src/backends/xor/flat_xor_3.c \