summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Lambert <eric_lambert@xyratex.com>2014-09-10 17:51:28 -0700
committerEric Lambert <eric_lambert@xyratex.com>2014-09-10 17:51:28 -0700
commitac395fdd9a23692c1b15bed7b9c9885e8119d7c2 (patch)
treee6796baa7b9903aec284836655cef8c8692a16bc /configure.ac
parent512353f8be456f9f8045faafbdb3356a4dbdb8ad (diff)
parentc85e1bacd36ca83ece37d70ae63409d010aef0cf (diff)
downloadliberasurecode-ac395fdd9a23692c1b15bed7b9c9885e8119d7c2.tar.gz
Merge branch 'newapi' of https://bitbucket.org/tsg-/liberasurecode into newapi
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 45 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4b5e6e9..5312850 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,3 +1,6 @@
+################################################################################
+# Standard Stuff
+################################################################################
AC_INIT(liberasurecode,0.9.10)
AC_GNU_SOURCE
@@ -25,13 +28,20 @@ AC_PROG_MAKE_SET
AX_EXT()
+################################################################################
+# System Headers
+################################################################################
dnl Check for C library headers
AC_HEADER_STDC
-AC_CHECK_HEADERS(sys/types.h stdio.h stdlib.h stddef.h stdarg.h malloc.h memory.h \
- string.h strings.h inttypes.h stdint.h ctype.h math.h iconv.h \
- signal.h dlfcn.h pthread.h unistd.h limits.h errno.h syslog.h)
+AC_CHECK_HEADERS(sys/types.h stdio.h stdlib.h stddef.h stdarg.h \
+ malloc.h memory.h string.h strings.h inttypes.h \
+ stdint.h ctype.h math.h iconv.h signal.h dlfcn.h \
+ pthread.h unistd.h limits.h errno.h syslog.h)
AC_CHECK_FUNCS(malloc calloc realloc free openlog)
+#################################################################################
+# Debug/coverage Options
+#################################################################################
AC_ARG_ENABLE([debug],
[ --enable-debug Turn on debugging],
[case "${enableval}" in
@@ -74,15 +84,47 @@ dnl Expand the sources and objects needed to build the library
AC_SUBST(ac_aux_dir)
AC_SUBST(OBJECTS)
+#################################################################################
+# Doxygen Documentation
+#################################################################################
+AC_CHECK_PROG(DOXYGEN, doxygen, true, false)
+AM_CONDITIONAL(HAVE_DOXYGEN, $DOXYGEN)
+AC_SUBST(HAVE_DOXYGEN)
+
+dnl Let people disable the doxygen stuff.
+AC_ARG_ENABLE(doxygen, [ --enable-doxygen Use doxygen to build documentation (default=auto)],
+ enable_doxygen="$enableval",
+ enable_doxygen=auto)
+
+if test x$enable_doxygen = xauto ; then
+ if test x$DOXYGEN = xtrue ; then
+ enable_doxygen=yes
+ else
+ enable_doxygen=no
+ fi
+fi
+
+dnl NOTE: We need to use a separate automake conditional for this
+dnl to make this work with the tarballs.
+AM_CONDITIONAL(ENABLE_DOXYGEN, test x$enable_doxygen = xyes)
+
+################################################################################
+# Output Files
+################################################################################
AC_CONFIG_FILES([\
src/builtin/null_code/Makefile \
src/builtin/xor_codes/Makefile \
src/Makefile \
test/Makefile \
+ doc/Makefile \
Makefile \
erasurecode.pc \
Xorcode.pc
])
+AM_CONDITIONAL([HAVE_DOXYGEN], [test -n "$DOXYGEN"])
+AM_COND_IF([HAVE_DOXYGEN],
+ [AC_CONFIG_FILES([doc/doxygen.cfg])])
+
AC_OUTPUT