summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Ringer <jonringer117@gmail.com>2021-10-27 16:40:10 -0700
committerAzat Khuzhin <azat@libevent.org>2023-05-14 22:43:47 +0200
commit1f1593ff27bdf51c3e1c45b92cfb0ac931960298 (patch)
tree591bf3115c8b2fed9e88c68d0ea63460702d5689 /CMakeLists.txt
parentfe610f2cdcca98402ec6d104ab6b565699dcc3e6 (diff)
downloadlibevent-1f1593ff27bdf51c3e1c45b92cfb0ac931960298.tar.gz
Use GNUInstallDirs for mapping installation directories
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ce72bbd..7b6ad7e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1621,8 +1621,10 @@ endif()
# Installation preparation.
#
+include(GNUInstallDirs)
+
set(EVENT_INSTALL_CMAKE_DIR
- "${CMAKE_INSTALL_PREFIX}/lib/cmake/libevent")
+ "${CMAKE_INSTALL_LIBDIR}/cmake/libevent")
export(PACKAGE libevent)