summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAzat Khuzhin <a3at.mail@gmail.com>2017-03-13 22:02:45 +0300
committerAzat Khuzhin <a3at.mail@gmail.com>2017-03-13 22:09:27 +0300
commit2d2299cf7a1a035e4cd7a8e5f6efefc9603ebd55 (patch)
treecbd935c7b9141e119787bd5040a23104fc7b8e8d /CMakeLists.txt
parent882f537c409d9c51ede581a3e13de7519227edb7 (diff)
downloadlibevent-2d2299cf7a1a035e4cd7a8e5f6efefc9603ebd55.tar.gz
cmake: add <pthread.h> only for non-win32
Fixes: b2b4b4d74e78a3e4fe7a74224d1e6aada5bde351 ("cmake: add <pthread.h> into CMAKE_REQUIRED_INCLUDES for sizeof(pthread_t)")
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 275c8e99..22c13eac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -476,7 +476,9 @@ else()
endif()
if (NOT EVENT__DISABLE_THREAD_SUPPORT)
- list(APPEND CMAKE_EXTRA_INCLUDE_FILES pthread.h)
+ if (NOT WIN32)
+ list(APPEND CMAKE_EXTRA_INCLUDE_FILES pthread.h)
+ endif()
CHECK_TYPE_SIZE(pthread_t EVENT__SIZEOF_PTHREAD_T)
endif()