summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 275c8e99..22c13eac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -476,7 +476,9 @@ else()
endif()
if (NOT EVENT__DISABLE_THREAD_SUPPORT)
- list(APPEND CMAKE_EXTRA_INCLUDE_FILES pthread.h)
+ if (NOT WIN32)
+ list(APPEND CMAKE_EXTRA_INCLUDE_FILES pthread.h)
+ endif()
CHECK_TYPE_SIZE(pthread_t EVENT__SIZEOF_PTHREAD_T)
endif()