summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMischa Jonker <mjonker@synopsys.com>2013-06-10 16:19:33 +0200
committerMischa Jonker <mjonker@synopsys.com>2013-06-14 10:06:30 +0200
commitb082e15091961373c03d10ed0251f619ebb6ed76 (patch)
treee905650623f1a869f53685cb1d0ac5c006f8b0e4 /configure.ac
parentc3c40e0290377d7cf948b072eedd8317c4bf215e (diff)
downloadlibffi-b082e15091961373c03d10ed0251f619ebb6ed76.tar.gz
Add ARC support
This adds support for the ARC architecture to libffi. DesignWare ARC is a family of processors from Synopsys, Inc. This patch has been tested on a little-endian system and passes the testsuite. Signed-off-by: Mischa Jonker <mjonker@synopsys.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0dc0675..a26cb46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,10 @@ case "$host" in
HAVE_LONG_DOUBLE='defined(__LONG_DOUBLE_128__)'
;;
+ arc*-*-*)
+ TARGET=ARC; TARGETDIR=arc
+ ;;
+
arm*-*-*)
TARGET=ARM; TARGETDIR=arm
;;
@@ -289,6 +293,7 @@ AM_CONDITIONAL(POWERPC_AIX, test x$TARGET = xPOWERPC_AIX)
AM_CONDITIONAL(POWERPC_DARWIN, test x$TARGET = xPOWERPC_DARWIN)
AM_CONDITIONAL(POWERPC_FREEBSD, test x$TARGET = xPOWERPC_FREEBSD)
AM_CONDITIONAL(AARCH64, test x$TARGET = xAARCH64)
+AM_CONDITIONAL(ARC, test x$TARGET = xARC)
AM_CONDITIONAL(ARM, test x$TARGET = xARM)
AM_CONDITIONAL(AVR32, test x$TARGET = xAVR32)
AM_CONDITIONAL(LIBFFI_CRIS, test x$TARGET = xLIBFFI_CRIS)