summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwillson-chen <53104026+willson-chen@users.noreply.github.com>2019-10-27 13:36:51 +0800
committerMike Frysinger <vapier@gmail.com>2019-10-26 22:36:51 -0700
commit6049895bf3b9f1ec38c8c2fe5f028ca19401a48e (patch)
treeb6275a44708cd4694c8197424e0ade5cefd8bd4f /CMakeLists.txt
parent820033c1528ae7e018ef66addde174173bc48490 (diff)
downloadlibgd-6049895bf3b9f1ec38c8c2fe5f028ca19401a48e.tar.gz
CMakeLists.txt: set cpack vendor and version dynamically
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd951da..f89188a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -247,10 +247,10 @@ add_custom_target(distclean ${GD_SOURCE_DIR}/cmake/distclean.sh)
SET(CPACK_PACKAGE_NAME "libgd")
SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "libGD, powerful and easy to use graphic library")
-SET(CPACK_PACKAGE_VENDOR "http://www.libgd.org")
-SET(CPACK_PACKAGE_VERSION_MAJOR "2")
-SET(CPACK_PACKAGE_VERSION_MINOR "1")
-SET(CPACK_PACKAGE_VERSION_PATCH "0")
+SET(CPACK_PACKAGE_VENDOR "https://www.libgd.org")
+SET(CPACK_PACKAGE_VERSION_MAJOR ${GDLIB_MAJOR})
+SET(CPACK_PACKAGE_VERSION_MINOR ${GDLIB_MINOR})
+SET(CPACK_PACKAGE_VERSION_PATCH ${GDLIB_REVISION}${GDLIB_EXTRA})
if(WIN32)
set(CPACK_GENERATOR ZIP)