summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-12-09 11:53:04 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-12-12 16:35:47 +0100
commit397ae74674698122b4696ac897e70de439a2d0c9 (patch)
treeca9f94e23cc1d2970c6aeb4990d1fa99610f8c03 /Makefile.am
parentd18b440a72407fc371ec17a2a983976b813e5d97 (diff)
downloadlibgphoto2-397ae74674698122b4696ac897e70de439a2d0c9.tar.gz
Add pull-translations target
Add pull-translations target to make it easier to pull translations from the Translation Project: make pull-translations
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 322491115..5071f33e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,6 +98,17 @@ git-checkout-po:
done; \
fi
+.PHONY: pull-translations
+if HAVE_RSYNC
+pull-translations:
+ $(RSYNC) -Lrtvz translationproject.org::tp/latest/libgphoto2/ $(top_srcdir)/po
+ $(RSYNC) -Lrtvz translationproject.org::tp/latest/libgphoto2_port/ $(top_srcdir)/libgphoto2_port/po
+else
+pull-translations:
+ echo "Error: Cannot pull translations: Could not find rsync at configure time."
+ exit 1
+endif
+
# Run "make update-po" in all po/ subdirs
.PHONY: update-po
update-po: