summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2021-11-01 12:39:35 -0400
committerAllen Winter <allen.winter@kdab.com>2021-11-01 12:39:55 -0400
commite9fc0434613e41cd05345b85992d754da279dd93 (patch)
tree393419ae1e4afd71e33ebab2775829044e639731 /CMakeLists.txt
parent1dcfc70b9958d7311e6b61c7ee307a4bd8c59032 (diff)
downloadlibical-git-e9fc0434613e41cd05345b85992d754da279dd93.tar.gz
CMakeLists.txt - fix DEF_USE_BUILTIN_TZDATA
DEF_USE_BUILTIN_TZDATA is True on Windows; False otherwise
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 284d6603..ee3df5d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -315,9 +315,9 @@ else()
endif()
if(WIN32 OR WINCE)
- set(DEF_USE_BUILTIN_TZDATA False)
-else()
set(DEF_USE_BUILTIN_TZDATA True)
+else()
+ set(DEF_USE_BUILTIN_TZDATA False)
endif()
libical_option(USE_BUILTIN_TZDATA "(Careful) Build using libical's built-in timezone data, else use the system timezone data on non-Windows systems. ALWAYS true on Windows. Non-Windows users should know what they're doing if they choose not to use system provided timezone data. The libical project does not guarantee that the built-in timezone data is up-to-date." ${DEF_USE_BUILTIN_TZDATA})
mark_as_advanced(USE_BUILTIN_TZDATA)