summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authornpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-01-21 21:14:06 +0000
committernpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-01-21 21:14:06 +0000
commit43ab6b0d11968f3a912b22737070975c9d1b6350 (patch)
tree1c3af4ca7157a97c1c355f99b6ddca4ae9bacc07 /libproxy/CMakeLists.txt
parenta83c265e215a9fa072e5cd3096ecb94d47466497 (diff)
downloadlibproxy-43ab6b0d11968f3a912b22737070975c9d1b6350.tar.gz
the "OMG, I think it builds on win32!" commit
git-svn-id: http://libproxy.googlecode.com/svn/trunk@486 c587cffe-e639-0410-9787-d7902ae8ed56
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
index fa3af13..9b2fa07 100644
--- a/libproxy/CMakeLists.txt
+++ b/libproxy/CMakeLists.txt
@@ -1,8 +1,8 @@
-set(lpSOURCES config_file.cpp dl_module.cpp module_manager.cpp module_types.cpp pac.cpp proxy.cpp url.cpp)
-if (UNIX OR APPLE)
- set(lpLIBRARIES m pthread dl)
+set(lpSOURCES config_file.cpp dl_module.cpp module_manager.cpp module_types.cpp proxy.cpp url.cpp)
+if (WIN32)
+ set(lpLIBRARIES ws2_32)
else()
- set(lpLIBRARIES "")
+ set(lpLIBRARIES m pthread dl)
endif()
set(BUILTIN_MODULES "")