summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <paul@paul-moore.com>2018-01-25 07:31:13 -0500
committerPaul Moore <paul@paul-moore.com>2018-01-25 07:31:13 -0500
commita6cc6331923430ea08711bcdfd5684394fab1a6b (patch)
tree73251c550afec3dc3b15515e2dff77b317af618c /Makefile.am
parent43d78737f323e0b87d21c2a5678b46ff26b00e30 (diff)
downloadlibseccomp-a6cc6331923430ea08711bcdfd5684394fab1a6b.tar.gz
build: add a "help" make target for the top level Makefile
Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 815446b..2642ce2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,5 +70,17 @@ coverity-tarball: coverity-build
ls -l libseccomp-coverity_$$rev.tar.gz
endif
+help:
+ @echo "libseccomp build system"
+ @echo " make targets:"
+ @echo " (none): build the library"
+ @echo " clean: remove all build artifacts"
+ @echo " check: run the automated regression tests"
+ @echo " check-build: build the library and all tests"
+ @echo " check-syntax: verify the code style"
+ @echo " distcheck: verify the build for distribution"
+ @echo " dist-gzip: build a release tarball"
+ @echo " coverity-tarball: build a tarball for use with Coverity (opt)"
+
clean-local:
${RM} -rf cov-int libseccomp-coverity_*.tar.gz