summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 815446b..2642ce2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,5 +70,17 @@ coverity-tarball: coverity-build
ls -l libseccomp-coverity_$$rev.tar.gz
endif
+help:
+ @echo "libseccomp build system"
+ @echo " make targets:"
+ @echo " (none): build the library"
+ @echo " clean: remove all build artifacts"
+ @echo " check: run the automated regression tests"
+ @echo " check-build: build the library and all tests"
+ @echo " check-syntax: verify the code style"
+ @echo " distcheck: verify the build for distribution"
+ @echo " dist-gzip: build a release tarball"
+ @echo " coverity-tarball: build a tarball for use with Coverity (opt)"
+
clean-local:
${RM} -rf cov-int libseccomp-coverity_*.tar.gz