summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2022-11-01 10:07:59 +0100
committerPaul Moore <paul@paul-moore.com>2023-04-03 14:53:33 -0400
commitbc2e1d155f4531eef5564639b50d3252af873273 (patch)
treec8513a1f9a390725e7d5749863cf6cac49f47ed1 /configure.ac
parent37889ffab861ff8538e4c5ff66d24709023de645 (diff)
downloadlibseccomp-bc2e1d155f4531eef5564639b50d3252af873273.tar.gz
configure.ac: Fix variable escaping for newer autoconf
When using autoconf macros, one has to be careful because some arguments as they may need additional escaping. In this particular case, the second argument passed to AC_DEFINE_UNQUOTED() is problematic as autoconf runs it in a subshell resulting in 'yes' being interpreted as a name of a variable instead of literal "yes" string. Putting quotes around it lets shell know we want string comparison. This problem was noticed with autoconf-2.71. Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Acked-by: Tom Hromatka <tom.hromatka@oracle.com> Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dfe3db0..f2f6862 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,7 +120,7 @@ AS_IF([test "$enable_python" = yes], [
])
AM_CONDITIONAL([ENABLE_PYTHON], [test "$enable_python" = yes])
AC_DEFINE_UNQUOTED([ENABLE_PYTHON],
- [$(test "$enable_python" = yes && echo 1 || echo 0)],
+ [$(test "$enable_python" = "yes" && echo 1 || echo 0)],
[Python bindings build flag.])
AC_CHECK_TOOL(GPERF, gperf)