summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2015-09-25 08:08:06 +0200
committerPavel Raiskup <praiskup@redhat.com>2015-09-25 08:29:21 +0200
commit03ec5f495586b8350a7653a440a6e563bd2b8889 (patch)
treee4e62af3690e43c57052f3fd3c80be56b7612901 /Makefile.am
parent351a88feee66eda6ce33eb06acdebb8e9c6d6716 (diff)
downloadlibtool-03ec5f495586b8350a7653a440a6e563bd2b8889.tar.gz
gnulib: sync with upstream
Blacklisting of duplicated ChangeLog entries is now much easier with new gitlog-to-changelog's option --ignore-matching -- so patching the script is not necessary. * Makefile.am ($(changelog)): Start ignoring entries having the 'Omit-from-ChangeLog.' "topic" line. Use TZ=UTC to generate the same ChangeLog regardless of the actual time-zone. * build-aux/git-log-fix: Put the "blacklist" mark at the beginning of each commit as that is requirement for --ignore-matching. * gl/build-aux/gitlog-to-changelog.diff: Removed. * gnulib: Sync with upstream. Signed-off-by: Pavel Raiskup <praiskup@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4d6074d..c4099cc7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -549,7 +549,8 @@ no_thanks = $(srcdir)/NO-THANKS
changelog_start_date = 2011-01-01
$(changelog): FORCE
$(AM_V_GEN)if test -d '$(srcdir)/.git'; then \
- $(gitlog_to_changelog) --amend=$(git_log_fix) \
+ TZ=UTC $(gitlog_to_changelog) --amend=$(git_log_fix) \
+ --ignore-matching=Omit-from-ChangeLog. \
--since=$(changelog_start_date) > '$@T'; \
rm -f '$@'; mv '$@T' '$@'; \
cat '$(changelog_old)' >> '$@'; \