summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNathan Hjelm <hjelmn@google.com>2023-02-13 11:04:11 -0700
committerTormod Volden <debian.tormod@gmail.com>2023-03-12 12:47:08 +0100
commit71dd672abe52d7c3a9c61373888a32984f0792a7 (patch)
tree20e40e1ca313ed052ccca7a663360aef4b03b937 /tests/Makefile.am
parentd2da7f9b1d52e55142775497ca170d9001e72c16 (diff)
downloadlibusb-71dd672abe52d7c3a9c61373888a32984f0792a7.tar.gz
tests: Add unit test for libusb_set_option
The behavior of libusb_set_option was not matching the documentation when the log level was set in the environment. This has been fixed but a regression test is needed to ensure the behavior does not deviate. This commit adds a set of unit tests to cover some of the functionality of libusb_set_option. Closes #1245 Signed-off-by: Nathan Hjelm <hjelmn@google.com> [Xiaofan: Add Windows setenv/unsetenv wrappers] Signed-off-by: Xiaofan Chen <xiaofanc@gmail.com> [Tormod: Fix test_no_discovery() build on Linux, add msvc build] Signed-off-by: Tormod Volden <debian.tormod@gmail.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d47d4ed..18da1eb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,9 +2,12 @@ AM_CPPFLAGS = -I$(top_srcdir)/libusb
LDADD = ../libusb/libusb-1.0.la
LIBS =
-stress_SOURCES = stress.c libusb_testlib.h testlib.c
+stress_SOURCES = stress.c testlib.c
-noinst_PROGRAMS = stress
+set_option_SOURCES = set_option.c testlib.c
+
+noinst_HEADERS = libusb_testlib.h
+noinst_PROGRAMS = stress set_option
if PLATFORM_POSIX
stress_mt_SOURCES = stress_mt.c