summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-01-01 11:02:37 +0000
committerDmitry Rogozhkin <dmitry.v.rogozhkin@intel.com>2020-10-16 09:35:48 -0700
commit37886813e71629363342a0503a83e39c8e840eb0 (patch)
treed040ca22a9edfd488409ba0ffdfc9cc902daed16 /configure.ac
parentf87858c4809a2dd9d48f89edd3c0057fd112413e (diff)
downloadlibva-37886813e71629363342a0503a83e39c8e840eb0.tar.gz
autotools: avoid -ldl if not required or not supported
ld: error: unable to find library -ldl
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2fce554..8484e43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -209,6 +209,11 @@ if test "$ac_cv_have_gnuc_visibility_attribute" = "yes"; then
[Defined to 1 if GCC visibility attribute is supported])
fi
+# Check for -ldl (often not required)
+AC_SEARCH_LIBS([dlopen], [dl], [], [
+ AC_MSG_ERROR([unable to find the dlopen() function])
+])
+
# Check for -fstack-protector
ssp_cc=yes
if test "X$CC-cc" != "X"; then