summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2fce554..8484e43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -209,6 +209,11 @@ if test "$ac_cv_have_gnuc_visibility_attribute" = "yes"; then
[Defined to 1 if GCC visibility attribute is supported])
fi
+# Check for -ldl (often not required)
+AC_SEARCH_LIBS([dlopen], [dl], [], [
+ AC_MSG_ERROR([unable to find the dlopen() function])
+])
+
# Check for -fstack-protector
ssp_cc=yes
if test "X$CC-cc" != "X"; then