summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMattia Rizzolo <mattia@mapreri.org>2021-07-29 12:14:03 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2022-01-16 14:59:02 +0100
commit967534504827fa79d39903ab0f94a7583a3925b9 (patch)
tree0ce26adbcada925c8e82c3458c1e611b7cea2a4a /Makefile.am
parent7c0253aadfe0ce69b077b66bf74fa26ff17728d1 (diff)
downloadlibxml2-967534504827fa79d39903ab0f94a7583a3925b9.tar.gz
Correctly install the HTML examples into their subdirectory.
Previous to this commit, the examples where installed haphazardly within all the other html documents, also overwriting index.html, for example. Signed-off-by: Mattia Rizzolo <mattia@mapreri.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 716a17fc..eb906b07 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1283,8 +1283,10 @@ install-data-local:
-$(INSTALL) -m 0644 $(srcdir)/testSAX.c $(DESTDIR)$(EXAMPLES_DIR)
-$(INSTALL) -m 0644 $(srcdir)/testHTML.c $(DESTDIR)$(EXAMPLES_DIR)
-$(INSTALL) -m 0644 $(srcdir)/testXPath.c $(DESTDIR)$(EXAMPLES_DIR)
+ @echo "If the documentation is installed, please also look at html/examples for more." > $(DESTDIR)$(EXAMPLES_DIR)/README
uninstall-local:
+ rm -f $(DESTDIR)$(EXAMPLES_DIR)/README
rm -f $(DESTDIR)$(EXAMPLES_DIR)/testXPath.c
rm -f $(DESTDIR)$(EXAMPLES_DIR)/testHTML.c
rm -f $(DESTDIR)$(EXAMPLES_DIR)/testSAX.c