summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2009-08-14 08:58:50 +0200
committerDaniel Veillard <veillard@redhat.com>2009-08-14 08:58:50 +0200
commit52588cf2f11ce43a184cc3c54fbe50dea19930da (patch)
treedca951b8ac15bba3fd3609c9cd63153010e7fe09 /Makefile.am
parent9d0f428e4daa0fd880dc9cc8a9417adf41a3106a (diff)
downloadlibxslt-52588cf2f11ce43a184cc3c54fbe50dea19930da.tar.gz
Adding a test program to check thread reentrancy
* xsltproc/testThreads.c: based loosely on libxml2 one, checks concurrent use of the same stylesheet and extensions reentrancy * config.h.in configure.in: we need to check for pthreads * Makefile.am xsltproc/Makefile.am: add the new program and insert in make check
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 839d4e5a..60bc051a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,12 +47,14 @@ dummy:
tests: dummy
@echo '## Running the regression test suite'
@(cd tests ; $(MAKE) MAKEFLAGS+=--silent tests)
+ @(cd xsltproc ; $(MAKE) MAKEFLAGS+=--silent tests)
@(if [ "@PYTHON_SUBDIR@" != "" ] ; then cd python ; $(MAKE) MAKEFLAGS+=--silent tests ; fi)
valgrind:
@echo '## Running the regression tests under Valgrind'
@echo '## Go get a cup of coffee it is gonna take a while ...'
@(cd tests ; $(MAKE) CHECKER='valgrind -q' tests)
+ @(cd xsltproc ; $(MAKE) CHECKER='valgrind -q' tests)
cleanup:
-@(find . -name .\#\* -exec rm {} \;)