summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 45ad78d..c0cf7ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,11 +9,11 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = yaml-0.1.pc
maintainer-clean-local:
- -rm -f aclocal.m4 config.h.in configure config/*
+ rm -f aclocal.m4 config.h.in configure config/*
-find ${builddir} -name Makefile.in -exec rm -f '{}' ';'
distclean-local:
- -rm -fr tests/run-test-suite
+ rm -fr tests/run-test-suite
-git worktree prune
.PHONY: bootstrap
@@ -31,5 +31,6 @@ test-suite: tests/run-test-suite
test-all: test test-suite
tests/run-test-suite:
- git fetch origin run-test-suite:run-test-suite
+ -git branch --track run-test-suite origin/run-test-suite
+ -git worktree prune
git worktree add $@ run-test-suite