summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIngy döt Net <ingy@ingy.net>2018-01-06 00:03:42 -0800
committerIngy döt Net <ingy@ingy.net>2018-01-06 14:39:12 -0800
commitaa10f65706b474987d17a6b66ae087f823758e6f (patch)
treeed824924fe2a412198b33dfc46b73865646a8a31 /Makefile.am
parente4aee06ff401668404de21b4af4c6a90be0f35a6 (diff)
downloadlibyaml-git-aa10f65706b474987d17a6b66ae087f823758e6f.tar.gz
Fix problems in CI failures (travis and semaphore)
In the Makefile.am, switched out the fetch (which can have auth problems in certain envs) with a simple branch per @perlpunk++'s suggestion. With the new test branches, travis had a problem in that it only clones one branch and we need the other branch refs to be available. Fixed this by fetching the other branch refs. I also cleaned up the travis YAML file. The Ubuntu 14.04 docker image (used by semaphoreci) had an older git, without the worktree command, so I made it install the latest git from a ppa. Renamed tests/run-tests.sh to tests/run-all-tests.sh for tab completion conflict reasons.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 45ad78d..c0cf7ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,11 +9,11 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = yaml-0.1.pc
maintainer-clean-local:
- -rm -f aclocal.m4 config.h.in configure config/*
+ rm -f aclocal.m4 config.h.in configure config/*
-find ${builddir} -name Makefile.in -exec rm -f '{}' ';'
distclean-local:
- -rm -fr tests/run-test-suite
+ rm -fr tests/run-test-suite
-git worktree prune
.PHONY: bootstrap
@@ -31,5 +31,6 @@ test-suite: tests/run-test-suite
test-all: test test-suite
tests/run-test-suite:
- git fetch origin run-test-suite:run-test-suite
+ -git branch --track run-test-suite origin/run-test-suite
+ -git worktree prune
git worktree add $@ run-test-suite