summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2020-11-09 20:26:30 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2020-11-09 20:26:30 -0500
commit5e711068e4afb2d2b93af55f449f3af3e7170f95 (patch)
tree63cd224be5c04d59e45414ca74706f9fe551e2cd /configure.ac
parent169d8d3608fb90e4f00ec77d149788e59a6fc8d5 (diff)
downloadlighttpd-git-5e711068e4afb2d2b93af55f449f3af3e7170f95.tar.gz
[build] check for xxhash in more ways
pkg-config libxxhash.pc might not be provided with xxhash < 0.7.3 x-ref: "Update build-dep for xxhash [...]" https://salsa.debian.org/debian/lighttpd/-/merge_requests/29
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 97ced9ea..a47980a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1204,7 +1204,13 @@ if test "$WITH_XXHASH" != no; then
CPPFLAGS="$CPPFLAGS -I$WITH_XXHASH"
else
PKG_CHECK_MODULES([XXHASH], [libxxhash], [], [
- AC_MSG_ERROR([xxhash not found, install it or build without --with-xxhash])
+ AC_CHECK_LIB([xxhash], [XXH_versionNumber],
+ [XXHASH_LIBS=-lxxhash],
+ [AC_MSG_ERROR([xxhash not found, install it or build without --with-xxhash])]
+ )
+ AC_CHECK_HEADERS([xxhash.h], [],
+ [AC_MSG_ERROR([xxhash not found, install it or build without --with-xxhash])]
+ )
])
fi