summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 97ced9ea..a47980a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1204,7 +1204,13 @@ if test "$WITH_XXHASH" != no; then
CPPFLAGS="$CPPFLAGS -I$WITH_XXHASH"
else
PKG_CHECK_MODULES([XXHASH], [libxxhash], [], [
- AC_MSG_ERROR([xxhash not found, install it or build without --with-xxhash])
+ AC_CHECK_LIB([xxhash], [XXH_versionNumber],
+ [XXHASH_LIBS=-lxxhash],
+ [AC_MSG_ERROR([xxhash not found, install it or build without --with-xxhash])]
+ )
+ AC_CHECK_HEADERS([xxhash.h], [],
+ [AC_MSG_ERROR([xxhash not found, install it or build without --with-xxhash])]
+ )
])
fi