summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2022-01-05 16:22:54 +0000
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-06 02:03:31 -0500
commitc0f040eae744e8688045d892d4fa150a7041a82b (patch)
treebff369965cf00913501df5781cfb59da6f403faf /tests/CMakeLists.txt
parent1b11cd7aebfbc6a944ff21961dc44a5e537a92f6 (diff)
downloadlighttpd-git-c0f040eae744e8688045d892d4fa150a7041a82b.tar.gz
[build] Haiku build fix (fixes #3136)
Haiku needs to link to additional lib -lnetwork for socket funcs (similar to Solaris need for -lsocket -lnsl) (edited: gstrauss) x-ref: "haiku build fix proposal" https://redmine.lighttpd.net/issues/3136
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 444e7430..a9e83f33 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -5,6 +5,8 @@ if(WIN32)
endif()
if(CMAKE_SYSTEM_NAME MATCHES "SunOS")
set(SOCKLIBS socket nsl)
+elseif(CMAKE_SYSTEM_NAME MATCHES "Haiku")
+ set(SOCKLIBS network)
endif()
if(SOCKLIBS)
target_link_libraries(fcgi-responder ${SOCKLIBS})