summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 444e7430..a9e83f33 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -5,6 +5,8 @@ if(WIN32)
endif()
if(CMAKE_SYSTEM_NAME MATCHES "SunOS")
set(SOCKLIBS socket nsl)
+elseif(CMAKE_SYSTEM_NAME MATCHES "Haiku")
+ set(SOCKLIBS network)
endif()
if(SOCKLIBS)
target_link_libraries(fcgi-responder ${SOCKLIBS})