summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2022-01-05 16:22:54 +0000
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-06 02:03:31 -0500
commitc0f040eae744e8688045d892d4fa150a7041a82b (patch)
treebff369965cf00913501df5781cfb59da6f403faf /tests/meson.build
parent1b11cd7aebfbc6a944ff21961dc44a5e537a92f6 (diff)
downloadlighttpd-git-c0f040eae744e8688045d892d4fa150a7041a82b.tar.gz
[build] Haiku build fix (fixes #3136)
Haiku needs to link to additional lib -lnetwork for socket funcs (similar to Solaris need for -lsocket -lnsl) (edited: gstrauss) x-ref: "haiku build fix proposal" https://redmine.lighttpd.net/issues/3136
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 44355777..b1a38399 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -7,6 +7,8 @@ if target_machine.system() == 'sunos'
socket_libs = [ compiler.find_library('socket')
, compiler.find_library('nsl')
]
+elif target_machine.system() == 'haiku'
+ socket_libs = [ compiler.find_library('network') ]
endif
executable('fcgi-responder',